Home > 分享 > 在ubuntu或者debian系统下安装VPN服务,支持windown10客户端

之前使用了好多方法配置VPN服务,先是PPTPD,后来发现十分不稳定。后来改用IPSec (& L2TP),iOS和Mac系统都可以正常使用,但是win10系统无法连接使用。今天发现一个新的解决方案,简单易用,无需配置证书,可以支持所有客户端。
下面一步一步跟我来操作:
curl -L -O https://raw.github.com/philplckthun/setup-strong-strongswan/master/setup.sh
chmod +x setup.sh
vi setup.sh

[ -z “$STRONGSWAN_VERSION” ] && STRONGSWAN_VERSION=”5.5.1″
改为
[ -z “$STRONGSWAN_VERSION” ] && STRONGSWAN_VERSION=”5.5.3″
这部分很重要,低版本的strongswan无法支持windows10.
sudo ./setup.sh
根据提示,一步一步安装即可,其中需要注意的是:
a username: 用户名
a password: 密码
a PSK (pre-shared key):公钥,这个最好设置一个自己能记住的复杂的,因为客户端链接都需要填写。

This installs the vpn-assist init.d script. Systemd is backwards compatible to these scripts and thus you can use it to start|stop|restart the VPN server, which should also start itself automatically on startup.

You can manage accounts for your VPN via /etc/ipsec.secrets and etc/ppp/chap-secrets. @zackdevine’s account managing script automates this process

本站内容受著作权法保护。个人 blog 转载时请遵循 “署名-非商业用途-保持一致” 的创作共用协议;商业网站或未授权媒体不得复制本站内容。
Categories: 分享 Tags:

Comments (0) Trackbacks (0) 本篇共有 0 篇评论↓
  1. No comments yet.
  1. No trackbacks yet.